CVE-2025-9390
vim: vim xxd xxd.c main buffer overflow
Severity
ModerateRed Hat Product Security
CVSS 3.1
Review impact separately from score.
Published · August 24, 2025
Updated · September 1, 2026
Description
A vulnerability was found in the xxd component of Vim in the main function of src/xxd/xxd.c. This flaw allows a local attacker to trigger a buffer overflow, which leads to a denial of service.
Statement
This vulnerability is marked MODERATE for a few reasons: first, because it's effect is localized within a victim's system. second, the buffer overflow is caught by compiler-level protection mechanisms before it can cause memory corruption, but represents a genuine security vulnerability that could be exploited in unprotected builds. The vulnerability is detected by GCC's fortify source protection mechanism and occurs when xxd processes input files with binary output (-b) and EBCDIC encoding (-E) flags, leading to buffer overflow conditions that trigger abort signals due to stack protection mechanisms.
CVSS score applicability
The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.
Mitigation
Upgrade to Vim version 9.1.1616 or later to address this issue.
CVSS / CWE
CVSS 3.1 · 4.4CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
CWE-120 · Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')