CVE Database›Document archive›CVE-2026-19203

CVE-2026-19203

org.eclipse.jetty/jetty-http: Jetty: HTTP request smuggling via crafted chunked requests

Loading…

Severity

Important

Red Hat Product Security

8.2

CVSS 3.1

Review impact separately from score.

Published · September 8, 2026

Updated · November 2, 2026

Description

A flaw was found in Jetty. A remote attacker can exploit this vulnerability by sending specially crafted HTTP/1.1 chunked requests. This can cause Jetty and an intermediary proxy to interpret different request boundaries, potentially leading to HTTP request smuggling. This issue arises from Jetty's acceptance of a lone Line Feed (LF) character as a terminator during chunked request parsing.

Statement

Jetty in affected Red Hat products may permit remote, unauthenticated HTTP request smuggling when specially crafted HTTP/1.1 chunked requests traverse an intermediary that interprets request boundaries differently. Jetty 12.1 uses RFC 9110 compliance by default and is not affected unless configured to use legacy RFC 7230 or RFC 2616 compliance modes. Remediation is being pursued for vulnerable shipped versions.

CVSS score applicability

The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.

Mitigation

Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

CVSS / CWE

CVSS 3.1 · 8.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N

CWE-444 · Inconsistent Interpretation of HTTP Requests